NEW ARMORTEK MODEL ANNOUNCED The iconic M3 Lee/ Grant Medium Tank
Read More: https://www.armortek.co.uk/m3-lee-grant-medium-tank/
Image

Servo Causing Static In The Speaker System

Forum for discussion relating to the Panther
Post Reply
Lewis Sleep
Posts: 23
Joined: Mon Oct 13, 2014 5:38 pm
Location: Plymouth, Devon, United Kingdom

Servo Causing Static In The Speaker System

Post by Lewis Sleep » Tue Jun 02, 2015 7:05 pm

Hello everyone

Would any of you know how to resolve the static sound that is being played through the speakers when I use a servo to operate the machine gun?

I have the newer electronic system installed so I'm not really sure why its making this static sound.

Any help would be appreciated. :D

Regards

Lewis 8)

User avatar
Stephen White
Site Admin
Posts: 1876
Joined: Sat Oct 11, 2008 7:05 pm
Location: Somerset

Re: Servo Causing Static In The Speaker System

Post by Stephen White » Tue Jun 02, 2015 7:46 pm

Lewis - I've just had exactly that problem with my Cent. If you look at my thread, I've described a fix which works for digital servos. I tried using a ferrite ring on the servo lead but that wasn't effective. i then ran a parallel power output from the battery to a BEC which supplies the required voltage to the servo. You would need to make up a modified servo lead to feed power to the servo from the BEC and signal from the Rx. It's very easy to do, you just need to pull the appropriate pins from the respective plugs and tape them back.

Hope this helps.

Stephen

Lewis Sleep
Posts: 23
Joined: Mon Oct 13, 2014 5:38 pm
Location: Plymouth, Devon, United Kingdom

Re: Servo Causing Static In The Speaker System

Post by Lewis Sleep » Tue Jun 02, 2015 9:23 pm

Hello Stephen,

Thanks for making the time to reply about this problem I am having, ill have a look at your thread & I will give it a go.

Many Thanks

Regards

Lewis 8)

Post Reply